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Welcome
Welcome to the Advanced Database Exercise Booklet. Here you’ll find practical exercises
that you can complete to help you learn the topics covered in the Student Workbook. In the
workbook, you’ll find references that tell you when to do each exercise.

Summary Tasks
This Exercise Booklet also contains Summary Tasks that should be completed at the end of
each Learning Outcome. An instruction in the Student Workbook will tell you when you
should complete these tasks.

Contents
Database Exercise Booklet — Advanced
Learning Outcome 1
Exercise 1.1
Exercise 1.2
Exercise 1.3a
Exercise 1.3b
Exercise 1.4a
Exercise 1.4b
Exercise 1.5
Exercise 1.6
Exercise 1.7
Exercise 1.8
Exercise 1.9
Summary Tasks for Learning Outcome 1
Learning Outcome 2
Exercise 2.1
Exercise 2.2
Exercise 2.3
Exercise 2.4
Exercise 2.5
Exercise 2.6
Summary Tasks for Learning Outcome 2
Learning Outcome 3
Exercise 3.1
Exercise 3.2a
Exercise 3.2b
Exercise 3.2c
Exercise 3.3
Summary Tasks for Learning Outcome 3

1
1
1
2
3
5
6
7
9
14
15
17
20
21
25
25
25
26
28
30
31
35
37
37
38
41
44
45
51

PC Passport Support Materials (Macintosh)

Database Exercise Booklet —
Advanced
Learning Outcome 1
Exercise 1.1
Complete the following questions:
1. What is a database?

2. What are records?

3. What is a field?

4. Describe the purpose of the four modes in FileMaker® Pro.

5. What three ways can you use to move from one mode to another?

6. How can you get help in FileMaker® Pro?
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Exercise 1.2
Complete the following questions:
1. What is a Template?

2. List three of the templates available in the Education section.

3. What button would give you details of all available templates?

4. Give two reasons why you might want to separate the first name and last name fields
when creating a database.

5. What do you need to create between two tables to enable them to share information?

6. What is the difference between a one-to-one relationship and a one-to-many relationship?

7. List four fields you might want to have in a database to store details of your book
collection.
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Exercise 1.3a
Creating a database structure
1. In FileMaker® Pro, choose File menu > New Database.
2. Click Create a new file using a template, then select the Home category from the drop
down list.

Click Create a new file using a
template.
Select Home from the
drop-down list.

3. Click on Movie Library and then click the Template Info button.

Click on ‘Movie Library’. Read the information displayed.
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4. Click New Database at the top of the window, and then select Movie Library from the
Home category again. Click OK.
5. Select where you want your file to be saved, and then click the Save button to save your
Movie Library file.

6. The movie library template will be displayed ready for you to enter your data or amend as
required.

7. Close the file.
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Exercise 1.3b
Create a Database without using a Template
1.

In FileMaker® Pro, choose File menu > New Database.

2.

Click Create a new empty file, then click OK.

Click Create a new
empty file.

3.

In the dialog box that appears, type My First Database (choose a different folder, if
required), then click Save.
FileMaker® Pro creates the file on your disk. The database will open ready for you to
create your tables and fields.

4.

Close your file.
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Exercise 1.4a
Creating a database
1. Choose File menu > New Database.
2. If you see the New Database dialog box, choose Create a new empty file, then click OK.
If not, go to step 3.
3. Go to the Working Files folder and select it as the location for this file.
4. For File Name, type MyFile01.
5. Click Save.
The Define Database dialog box appears. By default, FileMaker® Pro creates a table for you,
with the same name as your file. You can change this name later if you want to.
Creating fields to store information.
1. To create the first field, type First Name in the Field Name box.
2. Notice that the field type is Text.

Name a field.

Specify the field type.

3. Click Create.
4. Type Last Name in the Field Name box.
5. Click Create.
6. Type Fee Paid in the Field Name box, select Number from the Type list, then click
Create.
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7. Type Date Paid in the Field Name box, select Date from the Type list, then click
Create.
8. Click OK.
You see the empty fields in a new, blank record. Field labels identify the fields. Your file is
ready for data entry.
Enter data

Field labels.

FileMaker® Pro automatically saves your changes as you work. This means that you do not
need to worry about having to stop and perform a save as you enter data or when you quit
your database. However, unlike other packages where you save manually, you cannot simply
close down your file and revert back to the last saved version. Therefore, care should be
taken when editing or deleting records. It is also important that you make regular backups,
which is explained later on.

Exercise 1.4b
Enter data into the database
Now you can begin to enter members’ data.
Create the first record
1. If you don’t see field boxes, press Tab to begin data entry.
2. Type Jane in the First Name field.
3. Press Tab to move to the next field.
4. Type Doe in the Last Name field.
5. Press Tab to move to the next field.
6. Type 25 in the Fee Paid field.
You will learn how to format number fields to display as currency in the next lesson.
7. Type 11/11/2004 in Date Paid. The completed record should look like this:
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Create another record
1. Choose Records menu > New Record.
2. As you did for Jane Doe’s record, enter the following data:
First Name
John
Mary
Peter
Anne

Last Name
Smith
Jenkins
Davies
Watson

Amount Paid
75
75
75
75

Date Paid
2/2/2004
3/3/2004
3/4/2004
4/4/2004

Your database now contains five records. Click the book icon to see each record.
Modify data in a record
Suppose you realise that Jane Doe paid £75, not £25. You can easily correct the entry.
1. Go to Jane Doe’s record.
2. Select the amount in Fee Paid.

3. Type 75.
4. Click an empty area outside a field to save the change.
5. When you are finished with this lesson, close each open file by choosing File menu >
Close.
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Exercise 1.5
Customising what you see
You will change a simple layout in this exercise to make it look like the Fee Information
layout in the sample file.
1. Open MyFile1.5.fp7.
2. Choose View menu > Layout Mode.
3. Choose Fee Information from the Layout pop-up menu.
You see a plain layout. You will modify this layout in different ways
4. In Layout mode, click the First Name field to select it.
5. Drag the handle at the lower-right corner of the field to the left until the field is smaller,
yet large enough to display the longest first name you expect in your file.
6. Choose View menu > Browse Mode.
7. Click Save to save changes to this layout, if prompted. FileMaker® Pro can save layout
changes automatically, or prompt you to save changes before leaving Layout mode. To
save layout changes automatically, select the Save layout changes automatically
checkbox in the Save changes to this layout dialog box.

8. In Browse mode, flip through the records.
If the field doesn’t display all names completely, return to Layout mode and make the
field larger.
9. Repeat this process for Last Name.
10. Click inside the Last Name field and drag it beside the First Name field.
11. Drag the Last Name field label above the Last Name field.
12. Drag the First Name field label above the First Name field.
13. Choose View menu > Browse Mode to see your results.
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Add a field
1. Choose View menu > Layout Mode if necessary.
2. Using the Field tool, drag the field to the layout, and place it below the First Name field.

Field Tool.

Drag the new field.

3. In the Specify Field dialog box, select the City field. Click the Create field label box.

Click here to create a field label.

4. Click OK.
5. Choose View menu > Browse Mode to see your field.
You see a city entered in each record. City data was entered previously, and the field holds
the data.
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Display a number as currency
You can display a number as currency, even though only the number is typed into the field.
1. In Layout Mode, Select the Fee Paid field.
2. Choose Format menu > Number.
3. Select options as shown here in the
Number Format dialog box.
4. Click OK.
5. Choose View menu > Browse Mode to see the formatted data.
Add colour to a layout part
You will change the colour of the top of the layout to match the colours of other layouts in the
file.
1. In Layout Mode, choose Fee Information from the Layout pop-up menu.
2. Select the Header tab to make that part of the layout active.
The Header label will become darker in colour when selected.
3. Choose the Fill colour palette.
Fill colour palette.

4. Choose Other Colour from the Fill colour palette. The header part uses a custom colour.
5. Select the Sliders icon and choose RGB Sliders from the Colours dialog box pop-up
menu.
Sliders icon.
Select RGB Sliders.
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6. Enter these values in the Colour dialog box:
Colour

Value

Red

170

Green

191

Blue

170

7. Click OK.
The header is now coloured.
Add text
You will add the name of the organization to the top of the layout, then format the text.
1. Choose View menu > Layout Mode.
2. Select the Text tool.

Text tool.
Select tool.

3. Click in the Header section where you want to begin the line of text.
4. Type The Corporate Travellers Club.
5. Click the selection tool to end the text entry.
Change text size and colour
1. Click the Corporate Travellers Club text to select the text block.
2. Choose Format menu > Text.
3. Choose Times from the Font list.
4. Choose Custom from the Size list, and type 28.
5. Click OK.
6. For Color, choose white or another colour.
7. Click OK.
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Add a graphic to the layout
Add a logo beside the club name.
1. Choose View menu > Layout Mode.
2. Click beside the Corporate Travellers Club text, where you want to place the club logo.
You will see no change onscreen yet.
3. Choose Insert menu > Picture.
4. Open the Working Files folder.
5. Make sure all file types are showing, and select logo.gif.
6. Click Open.
7. Drag the logo to move it if necessary.
8. Choose View menu > Browse Mode to see the finished layout.
9. When you are finished with this lesson, close each open file by choosing File menu >
Close.
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Exercise 1.6
Creating a columnar list
You will create a columnar list to display the first name, last name, company and membership
type of club members.
1. Open MyFile1.6.fp7.
2. Choose View menu > Layout Mode.
3. Choose Layouts menu > New Layout/Report.
4. For Layout Name, type List of Members.
5. Select Columnar list/report for the new layout type and click Next.
Select the Columnar list/report layout again, then click Next.
6. Double-click each of the following fields in the order you want it to appear in the list:
♦ Last Name
♦ First Name
♦ Company
♦ Membership Type

These fields move to the Layout fields list.

7. Click Next.
8. Click Next again to accept the default sort order.
9. Select Standard from the list of layout themes, and click Next.
10. Click Next on each of the two remaining panels to accept the defaults.
11. Click Finish.
The data in all records for the fields Last Name, First Name, Company, and Membership
Type appears in the List of Members layout. The completed layout is displayed in
Preview mode, which shows items as they will appear when printed.
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Exercise 1.7
Creating a label layout
In this section, you will use the New Layout/Report assistant to:
♦

Create a label layout.

♦

Select fields to include on the labels.

Create the label
1. Open MyFile1.6 if it is not already open.
2. Choose View menu > Layout Mode.
3. Choose Layouts menu > New Layout/Report.
4. For Layout Name, type Labels.
5. Select Labels for the new layout type.
6. Click Next.
7. Choose Avery 5160 from the Use label measurements for list.
8. Click Next.
Now you’re ready to specify the label contents.
Choose the fields that will appear on the labels
1. Double-click First Name in the list.
First Name moves to the Label Contents area. The insertion point flashes.

2. After First Name, type a space.
3. Double-click Last Name in the list.
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4. After Last Name, press Return. This moves the cursor to the next line.
5. Double-click Home Address 1 in the list, then press Return.
6. Double-click Home Address 2 in the list, then press Return.
7. Double-click City in the list.
8. Type a comma, then a space.
9. Double-click Country in the list.
10. Now you have set up the merge fields. Your label contents should look like this:

11. Click Next.
12. Click View in Layout mode.
13. Click Finish.
14. When you finish viewing your label layout, choose View menu > Preview Mode.
Your labels should look like those in the sample file.
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Exercise 1.8
Creating a form letter
In this exercise you will create a blank layout, create a text box to contain your text and add
merge fields for the recipient’s name and address.
Create a one-page blank layout
1. Choose View menu > Layout Mode.
2. Choose Layouts menu > New Layout/Report.
3. For Layout Name, type Welcome Letter.
4. Select Blank layout for the new layout type.
5. Click Finish.
6. On the layout, click the Header tab, then press Delete.
7. Click the Footer tab, then press Delete.
This letter will not use a header or footer.
8. Drag the Body tab down to about 11 inches.
When you release the mouse button, you will see the page boundary.
If you don’t see the page boundary, drag the Body tab down further.

Body tab and Page boundary.

9. Now drag the Body tab up to just above the page boundary.
The page boundary line will disappear. Dragging the body tab above the page boundary
limits your form letter to a single page.
10. Use the scroll bar at the bottom of the screen to scroll a few inches to the right. You see a
heavy dotted line along the right side. This is the right-side page boundary. Your letter
will be within these boundaries.
11. Scroll back all the way to the left.
12. Scroll up to the top of the layout.
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Create the text block
You will create a text block with a 2 inch margin on all sides.
1. Click the text tool.

The text tool
is selected.

2. Drag a rectangle starting about 2 inches from the top left side of the layout, and ending
about 2 inches from the bottom right side, as indicated by the page boundary lines.
When you release the mouse, the insertion point flashes in the top left of the text box.
You will type the letter inside this box.
Add the address
1. Choose Insert menu > Merge Field.
2. Select First Name in the list and click OK.
3. Type a space.
4. Choose Insert menu > Merge Field.
5. Select Last Name in the list and click OK.
6. Press Return.
7. Add merge fields for the street address, city, and country, with appropriate spaces, new
lines, and punctuation.
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Type the letter
1. Press Return twice to create two line spaces at the end of the address.
2. Start the salutation line: type Dear and a space.
3. Insert merge fields for the first and last name, separated by a space.
In your own letters, you can use more fields (for example, a title field) for a more elegant
salutation.
4. Type a comma and two line spaces.
5. Type the letter:
The Corporate Travellers Club welcomes you and your company to our organisation.
We look forward to doing business with you and hope you have many pleasant trips with
us!
Customise the letter with the company name
1. Click after the word company in the first paragraph.
2. Type a comma and a space.
3. Insert a merge field for the company name.
4. Type another comma.
Add the closing
1. Click at the end of the text and enter two line spaces.
2. Type Sincerely, and then enter four line spaces.
3. Type John Jones.
4. Enter a line space, then type President.
Your layout should look like the letter in the sample file.
5. Choose View menu > Browse Mode to see your letter.
It should look like the letter in the sample file without the letterhead.
See lesson 1.5 to learn how to add a logo.
When you are finished with this lesson, close each open file by choosing File menu > Close.
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Exercise 1.9
1. How do you delete a header section from a layout?

2. What does Validation do?

3. Why is it a good idea to select an item from a list rather than key in the required data?
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Summary Tasks for Learning Outcome 1
Put all you have learned together by performing the Summary Task. However if your tutor
feels you are ready you may wish to move to the assessment for Outcome 1.

Task 1
1. Create a new Database called Employees. Save it into your Working Folder.
2. Create the following fields, adding the comments as you go:
Employee Ref

Text

Unique code for each employee

First Name

Text

First name of employee

Surname

Text

Surname of employee

Telephone

Text

Employee’s Home Phone No.

Salary

Number

Employees current salary

Holiday

Number

Holiday entitlement

Date

Date

Date of joining

3. Move the Date field above the Salary field.
4. Enter the following information:
101

Mary

Williams

01236 456456

21/01/00

35000

30

132

Joe

Swanson

0141 223 4567

17/06/01

28000

30

136

Jerry

Alan

01698 765234

12/07/05

45000

28

137

Eve

Burt

01555 345745

21/08/05

18000

25

Task 2
1. Add the text “Staff Details” to the header.
2. Change the colour, size and font of your header text.
3. Re-arrange the fields as shown here.
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4. Set the salary to be displayed as currency.
5. Add the graphic CompanyLogo to the header section. Resize if necessary.
6. Add background colour to the body of your layout and colour the fields and field names
to contrast.

Task 3
Exercise 1:
1. Create a New Layout called Salary List.
2. The layout should be a Columnar list containing the following fields:
First Name, Surname, Salary
3. Choose an appropriate Layout theme and accept all other defaults.
Exercise 2:
1. Create a new layout called Employee Labels.
2. Set up a layout to display Avery 5160 labels containing the First name and Surname on
one line and Telephone on the next line.
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Exercise 3:
1. Create a new layout called Salary Increase Letter.
2. Choose a Blank layout for the layout type.
3. Your layout should not have a header or a footer.
4. Type in the letter displayed on the next page, using Merge Fields where appropriate:

Today’s Date
Dear <<First name>> <<Surname>>
I am pleased to inform you that your current salary of <<Salary>> will
be increasing by 10% from the start of next month.
The Management

Check out your letter in Browse mode. Make any amendments required.

Keep a copy of your work so you can perform other summary tasks on it in this exercise
book.
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Learning Outcome 2
Exercise 2.1
Open Exercise File1.fp7
1. Find the names of all the employees who work for DEF Ltd and who live in the USA.

2. Who works for XYZ and lives in either Finland, Germany or Denmark?

3. How many of DEF’s employees don’t live in the UK?

4. Change to the List of Members layout and sort the Found Set by Membership Type and
then by Last Name.
5. How many people paid their membership fee between July and December 2004?

Exercise 2.2
1. What is the purpose of a wildcard character when searching a database file?

2. What is a calculated field?

3. Explain the difference between an Operator and an Operand in a calculated field.

4. Give three examples of an arithmetic operator.

5. Find the full name of the employee whose surname is either Johnston, Johnstone or
Johnson. Use a wild card (*) to help you.
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Exercise 2.3
Define a value list.
1. Open MyFile2.3.fp7.
2. Choose Data Entry from the Layout pop-up menu if it is not already selected.
3. Choose File menu > Define > Value Lists.
4. Click New.
5. Name the new value list by typing Membership Types.
6. Click in the large box and enter the values for this list, New and Continuing, by typing
each value on its own line.

7. Click OK to close the Edit Value List dialog box.
8. Click OK to finish.
Assign a value list to a field and display it as radio buttons
1. Choose View menu > Layout Mode.
2. Select the Membership Type field.
3. Choose Format menu > Field Format.
4. For Format field as, choose Radio Button Set.
5. For Display values from, choose Membership Types.
Select Radio Button Set.
Select the Membership
Types value.
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6. Click OK. Your radio buttons should be visible in Layout mode.

Membership Type field
formatted as radio buttons.

7. In Browse mode, test your value list and buttons by clicking them
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Exercise 2.4
Create a calculation field
There are several different ways of formulating a calculation, each of which can yield the
correct result. The following method uses an If statement to compare the data entered in the
Membership Type field with one of the membership types. The calculation returns one of two
results.
1. Open MyFile2.3.fp7.
2. Choose File menu > Define > Database.
3. In the Define Database dialog box, click the Fields tab if it is not already selected.
4. For Field Name, type Renewal Fee.
5. For Type, select Calculation to make this a calculation field.

Select Calculation.

6. Click Create.
The Specify Calculation dialog box appears.
7. Select Locical functions from the View drop-down list.
8. Scroll through the list of formulas on the right side of the Specify Calculation dialog box
until you locate If (test ; resultOne ; resultTwo). Double-click this formula so that it
appears in the dialog box at the bottom of the window.

Select Logical functions.

Find and double-click
If(test;resultOne;resultTwo).

Formula will appear in this
dialog box.
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This formula has three parts: a test; a result if the test evaluates as true (resultOne); and a
result if the test evaluates as false (resultTwo). You will replace the placeholders test,
resultOne, and resultTwo with the actual components of the calculation.
9. Select the placeholder test and type Membership Type = “Continuing” exactly as it
appears here.
10. Select the placeholder resultOne, and type 100.
11. Select the placeholder resultTwo, and type 200.
12. Make sure the calculation result is set to Number.
The completed calculation.
Replace these placeholders with your calculation
Verify the type of data to be
returned by the calculation.

13. Click OK.
If you receive an error message, make sure that all spaces and punctuation are identical to
the formula shown above.
14. Click OK to close the Define Database dialog box.
The Renewal Fee field appears at the bottom of the layout. Depending on the size of your
screen, you may need to scroll down to see it.
Your calculation formula is now complete. When data is entered in the Membership Type
field, FileMaker® Pro will compare it to the word we are testing for, ‘Continuing.’ The test is
true if it matches this word, and the calculation will return your first result, 100. If it doesn’t
match, the test is false, and the second result is returned.

Test your calculation
To see if your calculation works, try changing the value in the Membership Type field to
Continuing, and notice the result in the Renewal Fee field—it should change as the
membership type changes.
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Exercise 2.5
Create a field for serial numbers
1. Open MyFile2.3.fp7
2. Choose File menu > Define > Database.
3. In the Define Database dialog box, click the Fields tab if it is not already selected.
4. For Field Name, type Member Number.
5. Select Number as the field type.
6. Click Create.
7. Click Options.
8. Select Serial number on the Auto-Enter tab. You don’t need to change the Generate
choice, or the amounts for next value or increment by for this exercise.

Select Serial
Number.

9. Click OK, then click OK again to close the dialog box.
The new field appears at the bottom of the layout. (You might need to scroll down to see
it.)
10. Test your new field entry option by choosing Records menu > New Record. Each time
you create a new record, the value in the Member Number field increments by one.
When you are finished with this lesson, close each open file by choosing File menu > Close.
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Exercise 2.6
Create a button
1. Open MyFile2.6.fp7.
2. Choose Data Entry from the Layout pop-up menu if it is not already selected.
3. Select View menu > Layout Mode to switch to Layout mode.
4. Click the Button tool.

Button tool.

5. Draw the button at the top of the layout.
Draw button here.

6. In the Specify Button dialog box, select the Go to Layout command from the list.
7. In the Options area, select the List of Members layout.
8. Select Rounded button for button style.

Specify the List of Members layout.

Select Rounded button.

9. Click OK.
10. Notice that the insertion point is now in the centre of your button. Type Go to List of
Members in your button to identify it.
11. Click outside the button.
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If you need to move the button, select it and drag it to the desired location, as with any other
layout element.
To test your button, go to Browse mode and click it. The button takes you to the List of
Members layout.

Create a script to preview the Labels Layout
1. Open My File2.6.fp7 if necessary.
2. Choose Scripts menu > ScriptMaker.
3. Click New.
4. In the Script Name text box, type Preview Labels Layout.
5. Select the Go to Layout script step and click the Move button. (You can also select and
move script steps by double-clicking them.)
1. Type Preview Labels Layout.

2. Select Go to Layout.

3. Click Move.

6. In the Specify area, select the Labels layout from the list of available layouts.

Specify a target
layout for the script
step.
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7. From the list on the left, scroll down and select the Enter Preview Mode script step, and
move it over to your script.

The finished script.

8. Click OK, then click OK again to close the dialog box.
9. To run the script you have just created, choose Scripts menu > Preview Labels Layout.
FileMaker® Pro displays the Labels layout and switches to Preview mode.
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Assign a script to a button
To assign the script you just created to the button you created earlier:
1. In MyFile2.6.fp7, choose Data Entry from the Layout pop-up menu.
2. Choose View menu > Layout Mode.
3. Double-click the button you created earlier in this lesson.
4. In the Specify Button dialog box, select the Perform Script script step from the top of
the list on the left.

5. In the Options area, for Current Script click Specify.
6. Select Preview Labels Layout from the list of available scripts, and click OK.
7. Leave the rest of the default button settings as they are and click OK to save this button.

Rename the button
1. Click the Text tool.
2. Click the button once. The text insertion point appears in the button.
3. Select the existing text and then type Preview Labels Layout to rename this button. It
may be necessary to resize the button after renaming it.
Test the button
In Browse mode, test the button by clicking it. Clicking this button performs the script, which
displays the Labels layout and switches to Preview mode.
When you are finished with this lesson, close each open file by choosing File menu > Close.
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Summary Tasks for Learning Outcome 2
Task 1
Open your Employees Database.
1. Display the Employees layout.
2. Click on File > Define > Database.
3. Add a new Text field to your Database called Office Location.
4. Define a Value List called Locations for the Office Location field. Values should be:
Office 1, Office 2, Office 3, Office 4, Office 5.
5. Display the value list as a Pop-up List.
6. Use the Format Painter to format the new field and it’s label to match the rest of
your layout.
7. Display the Salary List layout and add two new Calculation fields to your database: Pay
Rise and New Salary. Use the Pay Rise field to display the 10% pay rise for each
employee and the New Salary field to display the new salary for each employee.
8. Use the Format Painter to format the new fields and their labels to match the rest of your
layout.
9. Format the new fields to display 2 decimal places and a £ sign.

10. In Layout View, go to Layout > Set tab order to check the order of your tabs.
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Task 2
Open your Employees Database if necessary.
1. Display your Salary List layout in Layout view.
2. Add a rounded button to take you to Find Mode. Add the text Go to Find.
3. Display your Salary List layout in Layout view again if necessary.
4. Add a Script called Letter to take you to your Salary Increase Letter and display it in
Print preview.
5. Assign your script to a button. Add the text Display Letter.
6. Format the buttons to suit the colour of your layout.
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Learning Outcome 3
Exercise 3.1
1. What is a report?

2. What six things should you consider when designing a report for a client?

3. What is the difference between a summary report and a subsummary report?
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Exercise 3.2a
Creating a subsummary report
To create the Membership Type Report:
1. Open MyFile3.2.fp7.
2. In Layout mode, choose Layouts menu > New Layout/Report.
3. For Layout Name type Membership Type Report.
4. Select Columnar list/report for the new layout type and click Next.

5. Select Report with grouped data, and click Next.
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Select the fields used in this report
1. Select the first field to be used in this report, Membership Type, and move it to the
Layout fields list.
2. Select and move the Last Name field.
3. Select and move the First Name field.

4. Click Next.
5. Move the Membership Type field to the Report categories list to organise the records
by membership type.

Membership Type is referred to as a break field because you are using the contents of this
field to break the records into categories for your report.
6. Click Next.
7. Move the Last Name field to the Sort order list as shown on the next page. This sorts the
records in each group of membership types alphabetically by members’ last names.
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Notice that the break field Membership Type
appears automatically at the top of the Sort
order list to enable FileMaker® Pro to group
records by this category.

8. Click Next.
Select a theme and create the header and footer
1. Select the Standard theme to set the text size, colour, and style of the finished report.
2. Click Next.
3. Go to the Top centre list in the Header area and select Large Custom Text from the
drop-down list.
4. Type Membership Type Report for the header of the report and click OK.
5. Go to the Bottom centre list and select Page Number from the drop-down list to number
the pages in the report’s footer.

6. Click Next.
Create a script to run this report again
1. Click Create a script.
2. Leave Script Name as it appears. Click Next.
3. Click View the report in Preview mode if it is not already selected.
4. Click Finish.
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Exercise 3.2b
Creating a report with grouped data and totals
In the previous exercise, you created a report that grouped data in categories based on
common field values. In this exercise, you will create a similar report that also includes
subtotals for each category and a grand total for the entire report.
To create the Membership Fee Report:
1. Open MyFile3.2.fp7 if it is not already open.
2. In Layout mode, choose Layouts menu > New Layout/Report.
3. For Layout Name, type Membership Fee Report.
4. Select Columnar list/report for the new layout type and click Next.
5. Select Report with grouped data and then select Include subtotals and Include grand
totals.

6. Click Next.
Select the fields used in this report
1. Select the first field to be used in this report, Membership Type, and move it to the
Layout fields list.
2. Select and move the Last Name field.
3. Select and move the First Name field.
4. Select and move the Fee Paid field.
5. Click Next.
6. You want to organize the records by Membership Type. Move this field to the Report
categories list.
7. Click Next.
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8. Move the Last Name field to the Sort order list to sort the records in each group of
membership types alphabetically by members’ last names.
9. Click Next.
Specify subtotals and grand totals
A summary field is a type of field you can specify when you define fields. Summary fields
allow calculations across all of the records in your found set. In general, when you need to
total data across a number of records, you must use a summary field.
In the Membership Fee Report, you want to see subtotals for fees paid by each type of
member, New and Continuing, and to see a grand total of both groups’ fees at the end of the
report. To accomplish this, you will need to specify subtotal and grand total summary fields in
the New Layout/Report Assistant.
The summary field you will use is Membership Revenue, which has already been defined
for you. Membership Revenue totals the fees entered in the Fee Paid field.
1. For Summary field, click Specify and select Membership Revenue from the list of
available fields, then click OK.

2. For Category to summarise by, use the default value of Membership Type.
3. For Subtotal placement, use the default value of Below record group.
4. Click Add Subtotal to add the Membership Revenue field as the subtotal. This tells
FileMaker® Pro to create a subtotal of the membership fees that are paid beneath each
membership category.
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5. Click Next.
6. For Summary field, click Specify and select Membership Revenue from the list of
available fields, then click OK.
7. This tells FileMaker® Pro to use the Membership Revenue field in the grand total.
8. Click Add Grand Total to add the Membership Revenue field as the grand total at the
end of the report. This tells FileMaker® Pro to create a grand total of membership fees.

Click Next.

9. Click Next.
Select a theme and create the header and footer
1. Select the Standard theme to set the text size, colour, and style of the finished report.
2. Click Next.
3. Go to the Top centre list and select Large Custom Text.
4. Type Membership Fee Report for the header of the report and click OK.
5. Go to the Bottom centre list and select Page Number to number the pages in the
report’s footer.
6. Click Next.
Create a script to run this report again
1. Click Create a script.
2. Leave Script Name as it appears.
3. Click Next.
4. Click View the report in Preview mode if it is not already selected.
5. Click Finish.
6. When you are finished with this lesson, close each open file by choosing File menu >
Close.
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Exercise 3.2c
Previewing and Printing a Report
1. To preview a report before printing, select View menu > Preview Mode.
2. Set up your page preferences by clicking on File menu > Page Setup. Make sure your
page size is set to A4, and that your Orientation is as required.

3. To print the report, go to the File menu, click Print. Select your printer and then choose if
you want to print the whole report or selected pages, and how many copies you want.
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Exercise 3.3
Define a relationship to another table
1. Open MyFile3.3.fp7.
2. Choose File menu > Define > Database.
3. Click the Relationships tab.
You see the relationships graph. The relationships graph shows all the tables in the current
file.
When you work with tables in the relationships graph, you are using them to organise your
view into your data. Each table occurrence in the relationships graph represents a separate
view into your data. When you create a relationship between two tables, you make the data
stored in either table accessible to the other table, according to the match fields and the
criteria you establish for the relationship.
4. In the Members table, click the Company field and drag to the Company field in the
Companies table.

5. Release the mouse button. You see the relationship you have created.

6. Records are related when data in the Company field in one table matches the data in the
Company field in the other table.
7. Click OK.
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Display data from a related record
Once you’ve defined the relationship, you can modify a layout to display data using that
relationship. Here, you want to display the company address.
1. In MyFile10.fp7, choose the Corporate Account Information layout from the Layout
pop-up menu.
2. Choose View menu > Layout Mode.
3. Using the Field tool

, drag a field onto the layout.

You see a Specify Fields dialog box displaying the list of fields in this table.
4. Click Current Table (“Members”) and choose the Companies table from the list.
You now see a list of the fields in the related table Companies. The colons (::) before each
field name show that these are related fields, not fields defined in the Members table you are
currently working in. These related fields will display data from the related table.

Choose the table from the
table pop-up menu.

Make sure the Create field label option is
selected.

5. Click ::Company Address, then click OK.
6. Repeat steps 3–5 for City and Country.
7. Move the fields if necessary, and make the fields large enough to display all the data they
contain. The fields should look like this:

8. Choose View menu > Browse Mode and flip through the records to view company
addresses from the Companies table in the Corporate Account Information layout that is
based on the Members table.
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View data from a list of related records
Suppose you want to show all club members for each company. You also want to add new
members to the Members table without entering the company name for each.
Work with related records in the sample file
1. Open Sample File3.3.fp7 if necessary.
2. Choose the Companies layout from the Layout pop-up menu.
3. Browse through the records.
You see a list of members at each company. They are all individuals in the Members table.
Add to the list
1. Go to the ABC Company record.
2. Add a new member by clicking the first empty line under First Name.

Click here to enter a new
member for this company.

Displays a
list of
members
from the
related table.

3. Type Joe, then press Tab and type Williams in the last name field.
View the new record in the related table
1. Go to the Data Entry layout, which is based on the Members table.
2. Go to the last record.
You see Joe Williams’ record, with the company information filled in. You automatically
created this record when you typed Joe Williams into the list in the Companies table.
Add a new record and view it in the list
1. In the Data Entry layout, create a record for a new member who works at ABC
Company.
2. Now return to Companies layout, and look at the ABC Company record.
You see the new member in the list (scroll down if necessary).
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About working with lists of related records
In “View data from one related record” previously, a relationship between the Members
and Companies tables displays data (company addresses) from the Companies table. Here, the
same relationship displays data (member names) from the Members table. Relationships are
bidirectional.
There is more than one matching record in the related table because there is more than one
member from each company. A portal in the Companies table displays all the members for
each company.
When you added Joe Williams to the list of members who work at ABC Company, the
relationship automatically created a record for Joe Williams in the Members table. ABC
Company is automatically entered into the match field because the name was added to the
portal of the ABC Company record.
A new member added to the Members table automatically appears at the end of the members
list in the matching company record in the Companies table.
Display a list of related records
Create a portal to display matching records
1. Open MyFile3.3.fp7 if necessary.
2. Choose the Companies layout from the Layout pop-up menu.
A relationship must always be defined before you can display data from related records. You
will use the relationship to the Members table you defined earlier in this lesson. This
relationship must be edited to allow the creation of related records.
3. Choose File menu > Define > Database, and click the Relationships tab, if it isn’t
already selected.
4. In the relationships graph, double-click the relational operator
Relationship dialog box.
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5. In the Members table, select Allow creation of records in this table via this
relationship. This lets you add a name to the Members list.

Select this
checkbox

6. Click OK, and then click OK again to close the Define Database dialog box.
7. Choose View menu > Layout Mode.
8. Click the portal tool

and draw a box to hold the list of names.

9. In the Portal Setup dialog box, show related records from the Members table.
10. Leave the initial row value at 1. Change the Number of rows in the portal value to 7.
Each row displays one matching member record.
11. Select Show vertical scroll bar.

12. Click OK.
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Add the fields in the portal
1. In the Add Fields to Portal dialog box, select the First Name field and move it to the
Included fields list.
2. Select and move the Last Name field.
3. Click OK.
4. Use the text tool and create field labels for the First Name and Last Name field labels
above their respective fields in the portal.
The portal should look like this when you are done.

5. Choose View menu > Browse Mode to view your list of members.
Test your new structure: type the name of a new member at ABC Company, then look to see
if it appears in the Data Entry layout (It will be the last record.)
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Summary Tasks for Learning Outcome 3
Task 1
Open your Employees Database
1. Go to the Employees layout and assign each employee an Office Location from your
Value List.
2. Create a Columnar subsummary report called Employee Locations.
3. Set the report to display with grouped data, but no totals.
4. Select the fields Office Location, Employee Ref, First Name and Surname.
5. Organise the records by Office Location and sort by Employee Ref.
6. Add the header Staff Report by Location.
7. Add the page number and current date to the footer.

Task 2
Open your Employees Database if required
1. Add a new table called Locations to your database.
2. Add the fields as follows:
Office Location, Street, Town, Post Code (All text fields).
3. Set up a relationship between your two tables.
4. Print the relationship.
5. Add the following records to your Locations table:
Office 1

The Bridges

Edinburgh

EH1

Office 2

Campbell Road

Glasgow

G12 3TG

Office 3

Paterson Street

Aberdeen

AB3 4PH

Office 4

Main Street

Dumfries

D22 6TW
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6. Display your Employees layout and add the Town field to the right of the Office Location
field. You might need to resize the Office Location field.
7. Use the Format Painter to apply formatting to match the rest of the layout.

8. Display your Locations layout and add a Portal to display the first name and surname of
all employees who work in that office.
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Task 3
1. Export the following fields for use in a mail merge:
First Name, Surname, Salary, New Salary.
2. Open Microsoft Word and create a simple mail merge letter using the four exported fields
informing the employees about their pay rise.

3. Create a backup copy of your database.
4. Perform a find to find all employees who live in the UK.
5. Export the records as a Tab Separated Text file. Use the following fields:
Member Number, First name, Last Name, Company, Membership Type.
6. Open Microsoft Word and insert the records. Set up appropriate tabs.

You should (after consultation with your tutor) be able to do the Assessment for this
Unit.
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