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SQA Functional Skills ICT Practice Tasks
Introduction
This workbook is for users of SQA’s Functional Skills ICT assessments. The assessments have
been created in a system which is similar to, but not exactly the same as, applications such as
Microsoft Office. The workbook takes the user through each of the component parts of the ICT
online system and should be followed in conjunction with the assessment available at:
https://sqaoa.btlsurpass.co.uk/openassess/openassess.html?qRef=ictdev&eRef=ICTpractice

Instructions for each task during an actual assessment will appear in the Tasks window but for
the practice content available at the address above, instructions are contained within this
workbook. A sample task is shown.

Disclaimer
This material is designed to provide learners with an opportunity of familiarisation with the
functionality of the assessment software. It should be used to complement existing learning
materials and is not intended as preparation material for the ICT assessment.
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Folder viewer
You will need to use the Folder Viewer to find files and save files during the assessment.
Try the following:
•

Open the Folder Viewer by double clicking on the icon.

•

Find and open the file called readme.txt.
Hint 1: The file is in a folder called resources.
Hint 2: Double click on a file to open it.

You can also use the Folder Viewer to copy files. Try the following:
•
•

Open the Folder Viewer.
Find the file called readme.txt, and make a copy of it.
Hint: Select the file, click on the Copy button, then click on the Paste button.

You can also use the Folder Viewer to rename files. Try the following:
•
•

Open the Folder Viewer.
Rename the file called readme.txt to read it.txt.
Hint: to edit the name of a file, click on the file name once, wait for a second, then click
on it again.

You can also use the Folder Viewer to create new folders. Try the following:
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•
•

Open the Folder Viewer.
Create a new folder and give it the name my work.

LEVEL 2 ONLY
At Level 2 you should know how to use the Folder Viewer to create and organise your folders so
that your files can be easily located by you and others. Try the following:
•
•
•
•
•

Open the Folder Viewer.
Create a new folder and give it the name data files.
Open the data files folder.
Create two new folders, one called text files and the other called spreadsheet files.
Copy the file readme.txt into the text files folder you have just created.

Folder viewer hints and tips from the examiner
All Functional Skills ICT assessments will ask you to open files, create folders, and save files into
folders. Here are a few tips:
•

•

Learn to use the folder viewer. Start by completing the sample tasks listed here. Always
give your files and folders meaningful names. For example, when you create a new
folder, don’t just call it New Folder. A meaningful name (e.g. spreadsheets or
temporary files or task 4 files etc.) will give an idea of what the folder contains. This is
useful when trying to find files again.
At Level 2 you should be able to create and organise folders to make it easy to find files.
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Email
You will need to use the E-mail tool to send and receive emails and attachments during the
assessment.
Try the following:
•

Open the E-mail tool.

•

Look in the Inbox and open the email with the subject hello.
Hint: double click on an email in the Inbox to open the email.

•

Reply to the email.

You will also need to be able to save email attachments. Try the following:
•

Open the E-mail tool.

•

Look in the Inbox and open the email with the subject data.

•

Follow the instructions in the email.

You will also need to be able to send email attachments. Try the following:
•

Open the E-mail tool.
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•

Create a new email to ict@sqa.org.uk with the subject data and attach the data file you
saved in the task above.

•

Send the email.

LEVEL 2 ONLY
At Level 2 you should know how to add events to the calendar. The calendar is part of the Email tool. Try the following:
•
•
•
•

Open the E-mail tool.
Click on the Calendar button to open the calendar.
Click on the day, week, and month buttons at the top to see how this changes the
layout of the calendar.
Create a new appointment event a week from today. The event should start at 2.00pm
and end at 3.00pm. Call the event Functional Skills ICT revision.

Here are some hints about how to create the appointment above:
•
•
•
•
•
•
•

Click on the month button to get a view of the calendar by month.
Click on the day when you want to have the event.
Click on the New Event button.
Select New Appointment / Event.
Enter Functional Skills ICT revision as the subject.
Enter the start time as 14:00 and the end time as 15:00.
Click on the Confirm button.

Email hints and tips from the examiner
All Functional Skills ICT assessments will ask you to send and receive emails and handle
attachments. Here are a few tips:
•

•
•
•

Learn to use the E-mail tool. Start by completing the sample tasks listed here. Make sure
you know how to send emails, CC other email addresses, attach files etc. Remember,
any emails “sent” are only visible to you and the examiners, they do not get sent to real
email addresses.
When saving attachments, remember to save them in folders with meaningful names.
At Level 2, try creating different kinds of calendar events.
Also at Level 2, try creating folders within the E-mail tool, and moving emails between
email folders.
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Word Processor
You will need to use the Word Processor to create and edit documents during the assessment.
Try the following:
•

Open the Word Processor tool.

•

Type the following sentences into the Word Processor:
This is normal text
This is bold text
This is italic text
This is bigger text
This is red text
This is centred text

•

Now format each line to match the text – make the bold text bold, make the italic text
italic and so on.
Hint: select the text and then use the buttons on the toolbar to format it.

•

Change the order of the sentences in the document by using cut and paste. You can do
this either using the menu commands in the Edit menu, or using the Cut and Paste
buttons in the toolbar.
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•

Format some of the text as bullet points.
Hint: select the text you want to turn into bullet points then click on the bullet point
button in the toolbar.

•

Save the file: call it formatted.txt.

As well as inserting and formatting text, you can also include images in documents. Try this:
•

Open formatted.txt again.

•

Insert a picture into the document from clip art.
Hint: click on Insert, then Picture then Clip Art.

•

Move the picture you have inserted around in the document.
Hint: click on the picture, then cut it, then position the cursor where you want to move
it to, then paste the picture.

•

Change the size of the image.
Hint: click on the picture, then click on the Format menu, then click on Image Size.

You also need to know how to print documents. Try the following:
•

Open formatted.txt again.

•

Now print the file.
Hint: Click on the File menu, then Print. Remember, files you “print” do not actually get
printed out anywhere. However the system records the fact that you have printed the
file.

•

Print the file again, but this time in colour on the network printer in landscape
orientation at best quality on A3 paper.
Hint: you can set all of these options in the print dialogue which appears when you click
on the print button on the toolbar.

LEVEL 2 ONLY
At Level 2 you should know how to insert tables into a document. Try the following:
•
•
•
•

Open the Word Processor tool.
Insert a table into the document.
Hint: click on the Table menu, then click Insert Table.
Insert some text into the table.
Insert another row at the bottom of the table.
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Hint: put the cursor in the bottom row of the table, then click on the Table menu then
click on Insert row.
At Level 2 you should know how to run a spell check on a document. Try the following:
•
•
•

Open the Word Processor tool.
Type in some text.
Click on the Tools menu then click on Spell Check. You should see a dialog window
which says “Spell check is complete”. The spell check tool in the Word Processor is not
fully functional. That means it may not find any spelling mistakes you have made, so you
should still check your spellings yourself.

Word Processor hints and tips from the examiner
You will need to use the Word Processor in every Functional Skills ICT assessment. Here are a
few tips:
•

•
•
•
•

Learn to use the Word Processor. Start by completing the sample tasks listed here.
Make sure you know how to format text; use cut and paste; insert, position and re-size
images; and print documents. Remember, files you “print” do not actually get printed
out anywhere. However the system records the fact that you have printed the file.
Check that the information in your document is what was asked for in the assessment.
Check that there are no errors in your document – that you have copied any information
from the question or from a web site etc. accurately into your document.
Try to make sure there are no spelling errors. See below about the spell check tool.
It is good practice to spell check your documents – this means that it is something you
should always do when using a word processor. Using the spell checker in your
Functional Skills assessment shows the examiner that you know that you should spell
check your documents.
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Web Browser
You will need to use the Web Browser to find information on the internet during the
assessment. The “internet” you will have access to during the assessment is not the full
internet. There are only a few websites available, and these are not the same websites that you
would find on the real internet. However they will contain the information you are asked to find
in your Functional Skills assessment.
Try the following:
•

Open the Web Browser. It should open at the Searcharama page. Searcharama is the
search engine you will use to find the information you need.

•

Search for information about red foxes.
Hint: enter the words “red fox” in the search box and click on the Go button. You should
see two web pages found in your search results.

•

Look for the following information in the search results:
• What is the lifespan of a red fox?
• What is the habitat of a red fox?

•

When you have found the information, copy it into a new document.

Here are some hints about how to do the step above:
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•
•
•
•

Functional Skills assessments may ask you to copy information found in your searches
into a new document. This means you should open the Word Processor, copy the
information into the Word Processor, and then save it as a new document.
To copy text from a web page, use the mouse to select the text, then click on the Edit
menu then click on Copy.
To paste text into a document, put the cursor where you want the text in the Word
Processor, then click on the Edit menu, then click on Paste.
You can also copy the website address of the page where you find the information. To
do this, click in the Address box (near the top of the web browser window) and select
the address. Then you can copy it as you would any other text.

Web Browser hints and tips from the examiner
You will need to use the Web Browser in every Functional Skills ICT assessment. Usually at least
one question will ask you to find information on the internet. Here are a few tips:
•
•
•
•
•

Learn to use the Web Browser. Start by completing the sample tasks listed here. Make
sure you know how to search using the web browser.
Read the question carefully to see what you should be searching for. Often the question
will give you a good idea of what search terms you should use. “Search terms” are the
words you type into the internet search engine.
Make sure you know how to copy text and web addresses from the web browser into
the Word Processor.
Make you know how to add bookmarks and use previously saved bookmarks.
Hint: when you are searching for information, you should try different search terms.
Even if you think you have found the correct information straight away, you should try
another search using slightly different search terms. That way you can see if there is any
more information to be found, and you can check to make sure that the information you
found in your first search is correct.
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Spreadsheet
You will need to use the Spreadsheet tool during the assessment.
Try the following:
•

Open the Spreadsheet tool.

•

In cell A1, enter the number 3,
In cell A2, enter the number 2,
In cell A3, enter the number 1.
Hint: click on a cell to highlight it then enter the text. You can move between cells using
the tab key or the return key.

Well done, you have just entered data into the spreadsheet! Now we will use a simple formula
to add up the numbers you have entered. Try the following:
•
•

Use the mouse to select cells A1, A2 and A3.
Now click on the ∑ button on the toolbar. This is the sum function, it creates a formula
to add together the numbers in the selected cells. The formula will be put in the cell
under the ones you have selected, which is cell A4. Cell A4 should now have the value 6.

So now you know how to enter data and how to use the sum function. You can also format cells
in the spreadsheet. Try the following:
•

Click on cell A4 (which is the one with the formula in it).
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•

Click on the Format menu, then on Cells. From the Format Cells window which opens,
you can apply a format to the selected cell.

Here are some hints about how to do the step above:
•
•

To change the font size, click on the Font tab, then click Bold in the Font Style list and on
14 in the Font Size list.
To change the background colour, click on the Shading tab, and click on the red cell
(which has a 4 in it).

Here is an example to try where you will need to use everything you just tried above. Open the
file called sales.spr (it is in the Resources folder). The file contains sample sales data. Use the
facilities in the spreadsheet tool to work out and display:
•
•
•
•

the total number of sales each day
the total number of sales for each product type (CDs, DVDs, Games)
the total number of sales for the week.

Format the data so that all totals are shown in bold and the total number of sales for the
week is underlined.

So far you have just used the sum function, but there are others which you may be asked to
use. Here is an example of using the average function. Open the file called temperatures.spr (it
is in the Resources folder). The file shows the average temperature for London in the summer
months. We are going to calculate the average temperature over the 3 months. Try the
following:
•
•
•
•

Click in cell E2. This is where we are going to put the average value.
Click on the Insert menu, then Insert Function.
From the list of functions, select Avg (which is short for Average).
Now in the Data Range box, enter the following:
B2:D2
and click on OK. You should see the value 20.333 in cell E2, which is the average of the
values in cells B2 to D2.

•

As a final step, see if you can format the value to have only one decimal place.
Hint: click on the Format menu, then on Format Cells, then in the Field tab click on
Number in the Category list.

There is one other thing you will have to be able to do using the spreadsheet tool: create
charts. Here is how to create a very simple pie chart:
•

Open the file called temperatures.spr.
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•
•
•
•
•
•
•
•

Use the mouse to select cells B1 to D2 (so you are selecting the name of the months and
the data for each month).
Click on the Insert menu, then on Insert Chart.
In the Chart Type list, select Pie Chart.
Where it says Series in, select Rows.
Tick the box which says Use cells for labels.
Click on next, and in the Chart title box, enter Average temperatures.
Click on the Finish button. The chart should now be inserted into your spreadsheet.
If you want to move the chart, first click on it to select it, then click and drag the blue
bar at the top of the chart.

You will also need to be able to copy a chart from a spreadsheet into another document. Try
the following:
•

Click on the chart, then click on the Edit menu and click on Copy.

•

To paste the chart into a document or a presentation, put the cursor where you want
the chart in the document/presentation, then click on the Edit menu, then click on
Paste.

LEVEL 2 ONLY
At Level 2 you should know how to sort data in the spreadsheet. Try the following:
•
•
•
•
•
•
•

Open the file called people.spr. This file contains height and weight data for three
people. We are going to sort the data so that the tallest person is at the top and the
shortest is at the bottom.
Use the mouse to select cells A2 to C4 (so you are selecting the name of each person
and their height and weight).
Click on the Data menu, then on Sort.
Select B from the Sort by list, and select Descending next to it.
Click on OK.
The data will now be sorted in order of height, with Harry at the top.
Now try again, this time sorting by weight, so that the heaviest person is at the top and
the lightest at the bottom.

Spreadsheet hints and tips from the examiner
You will need to use the Spreadsheet tool in every Functional Skills ICT assessment. Here are a
few tips:
•

The spreadsheet tool works much like other spreadsheet software you will have used,
but there are differences. It is very important that you practise using the spreadsheet
13

•

tool so that you know how to use it in your Functional Skills assessment. Make sure that
you can do the following.
• Save and open spreadsheet files.
• Enter data.
• Copy and paste data.
• Format cells, including as currency and percentages.
• Use the sum function to add together values in your spreadsheet. Make sure you
know how to sum values in rows and in columns.
• Use other functions, including the average function.
You will also need to be able to create charts. Make sure that you know how to: do the
following.
• Create different chart types.
• Add titles to your chart, including X-axis and Y-axis titles for some chart types.
• Copy the chart into the Word Processor and Presentation tool.
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Database
You may need to use the Database tool during the assessment.
Try the following:
•

Open the Database tool.

•

Find and open the file called emails.db.
Hint: the file is in a folder called Resources.

The database you have just opened contains information about a group of people. For each
person, it gives their name, email address, age, and whether they are male (m), female (f), or
junior (j).
You should know how to create a report using the database tool. As a simple example, try the
following.
•

Create a report containing all the data in the file.
Hint: click on the Create menu, then click on Report. Give the report a name, and keep
table 1 as the selected table. Click OK.

You will see that a report tab has been added to the database, and that it contains a report
containing all the data in the file. If you save the database, then re-open it again, you will see
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that the report is still there. It gets saved along with the data in the file. If you want to delete a
report, try the following.
•
•

Select the report tab you want to delete.
Click on the Edit menu, then Delete Item. Confirm that you want to delete.

So far, so good, but usually you will have to select only certain information to go into a report.
What if the question was to say: “Produce a report containing the names of the females in the
list.”? This time you have to select only certain rows of the data, and only certain fields in each
row. The best way to do this is to create a query, and then use the query to create a report. Try
the following.
•
•
•
•
•
•
•
•

Click on the Create menu, then click on Query Wizard.
Give the query the following name: Females Query.
Keep table 1 as the selected table. Click Next.
The next step is to select the fields to use in the query. We want to select all of them.
Click on the >> button to copy all the fields to the right hand window. Click Next.
In the list of Fields on the left hand side, select both name and status.
Tick the Show box for both name and status.
In the Criteria box for status, enter the following:
=f
Click Finish.

You will see that a query tab has been added to the database, and that it contains just the name
and status of the females in the list. The next step is to produce a report from this query. Try
the following.
•
•
•
•

Click on the Create menu, then click on Report.
Call the report Females Report.
Select the Females Query query using the drop down. This will be where the data comes
from for the report.
Click OK.

You will see that a report tab has been added to the database.
LEVEL 2 ONLY
At Level 2 you should know how to use more complex queries to create reports.
Using the same database file (emails.db), produce a report containing the names of the males
in the list who are over 50.
Here are some hints:
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•
•

As before, you should create a query to select the data you need, and create a report
from the query.
Query hints:
• Select name, status, and age in the query wizard.
• For status enter =m for the Criteria.
• For age enter >50 for the Criteria.

Database hints and tips from the examiner
You may need to use the Database tool in your Functional Skills ICT assessment. Here are a few
tips.
•
•
•

Learn to use the Database tool. Start by completing the sample tasks listed here. Make
sure you know how to open and save database files, create queries, and create reports
from queries.
Spend some time trying out different query options in the Query Wizard. At Level 2,
make sure you know how to create more complex queries.
Make sure you know how to sort data using the buttons on the toolbar.

17

System Tasks
You may need to carry out one or more system tasks during the assessment.
The System Tasks icon is at the bottom right of the screen.

This is the System Tasks icon

Make sure you know how to do the following.
•
•
•

Run a virus check.
Set a new system password.
Mute the sound.

System tasks hints and tips from the examiner
•
•

When you are running a virus check, you should always Check for updates before
running the scan. This shows the examiner that you know it is good practice to run an up
to date virus check.
If you have to set a system password, make sure it is a strong one (e.g. mixture of upper
and lower case letters, at least 8 characters long, etc).
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Presentation
You may need to use the Presentation tool to create and edit presentations during the
assessment.

When you open the Presentation tool it always creates the first slide for you. Try it now. The
left hand side of the Presentation tool window shows the contents of the currently selected
slide (it is blank at the moment). The right hand side shows a list of all the slides in the
presentation. At the moment there is only one, and it is called Slide 1.
To begin with, try adding some text to slide 1.
•
•
•
•
•

Click on the Insert menu, then click on Text Box. A text box, shown as an orange
rectangle, will be inserted into the slide.
Double click with the mouse inside the text box, and enter the following text: My first
slide.
Now we want to move the text box to place it at the top of the slide. Using the mouse,
click and drag the text box to the top of the slide.
Now add in another text box, and enter the following text: Hello, and welcome to my
presentation.
Click and drag this text box so that it is underneath the first text box.

So far, so good, but in presentations you must make sure the text is big enough for people to
read. Try the following:
•

Using the mouse, double click inside the top text box, and then select all the text.
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•
•

Now on the right hand side of the toolbar you will see a drop down list, with 12
currently selected. This is the text size. Change this to 24. You will see that the text you
selected gets bigger: it has been set to size 24 text rather than size 12.
Now do the same for the other text box, but this time set the size to 20.

Now you can add another slide to your presentation. Try the following.
•
•
•
•

Click on the Add Slide button (on the right hand side).
You will see you can select the kind of slide to add. Select the one that says Title &
Picture and click on OK.
Double click with the mouse where it says DOUBLE CLICK HERE TO ADD PICTURE. Find
the image called presentation.gif on your computer and select that to insert it into the
presentation.
You can click and drag with the mouse to move the image to where you want it. You can
click on the bottom right hand corner of the image (where there is a black dot) to re-size
the image.

You can use the controls on the right hand side to Add Slides and Remove Slides. Try now to
add a new slide, and then remove it again.
You will also need to be able to save and print your presentations. Try the following.
•

Save your presentation.
Hint: click on File, then Save.

•

Now print the presentation.
Hint: click on File, then Print. Remember, files you “print” do not actually get printed
out anywhere. However the system records the fact that you have printed the file.

You should also know how to modify the settings on the master slide. Try the following.
•
•

Open the Presentation tool, and open the presentation you saved previously.
Modify the master slide setting to apply a white background to all slides.
Hint: click on the Modify menu, then click Master Slide Settings, then click on the
Background tab. From here you can set the background colour of all slides.

•

Modify the master slide setting to apply a Fade In slide transition to all slides.
Hint: click on the Modify menu, then click Master Slide Settings, then click on the
Preview Control tab. From here you can set the slide transition.
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Presentation hints and tips from the examiner
You may need to use the Presentation tool in your Functional Skills ICT assessment. Here are a
few tips.
•

•
•
•
•

Learn to use the Presentation tool. Start by completing the sample tasks listed here.
Make sure you know how to add and remove slides; insert and format text; use cut and
paste; insert, position and re-size images; modify the settings on the master slide; and
print documents. Remember, files you “print” do not actually get printed out anywhere.
However the system records the fact that you have printed the file.
Check that the information in your presentation is what was asked for in the assessment
question.
Check that there are no errors in your document – that you have copied any information
from the question or from a web site etc. accurately into your presentation.
Try to make sure there are no spelling errors. See below about the spell check tool.
The spell check tool in the Presentation tool is not fully functional. That means it may
not find any spelling mistakes you have made, so you should still check your spellings
yourself. However it is good practice to spell check your presentations – this means that
it is something you should always do when using the Presentation tool. Using the spell
checker in your Functional Skills assessment shows the examiner that you know that
you should spell check your presentations.
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